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1. Introduction 

Land Use and Land Cover (LULC) classification plays a critical role in understanding the 

physical and cultural landscape of a region. It provides a thematic representation of how 

the land surface is used and what it is covered with—such as built-up areas, forests, water 

bodies, and agricultural fields. LULC information is essential for urban planning, 

agricultural management, environmental monitoring, and disaster risk analysis. 

Remote sensing, through satellite imagery, offers a cost-effective, repetitive, and large-

scale way of capturing land surface information. Platforms like Landsat deliver multi-

spectral data with moderate spatial resolution (30m) and consistent temporal coverage 

making them suitable for Land Use/Land Cover (LULC) classification projects. Using 

image classification algorithms, these raw satellite images are processed into land cover 

maps. 

Classification methods are broadly categorized into supervised and unsupervised 

techniques. Supervised classification requires prior knowledge about land cover types 

(training data), while unsupervised classification discovers natural groupings in the data 

without such prior input.  

1.1 Objective of the Assignment 

The primary objective of this assignment is to prepare four LULC maps of a selected study 

area (e.g., Kaski District) using: 

 Two Supervised Classification Methods 

 Two Unsupervised Classification Methods 

The aim is to compare these methods based on their performance in identifying land cover 

classes and to understand their working principles and limitations. 

1.2 Classification Methods Used 

1) Supervised Classification 

Supervised classification uses user-defined training samples (ROIs) to instruct the 

algorithm on how to classify the rest of the image. Two methods are used here: 
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i. Maximum Likelihood Classification (MLC) 

This statistical method assumes that the spectral values for each class are normally 

distributed. It calculates the probability of each pixel belonging to each class and 

assigns the pixel to the class with the highest likelihood. MLC is considered robust 

when training data is reliable and classes are spectrally separable. 

ii. Minimum Distance to Mean (MDM) 

This simpler approach computes the Euclidean distance between a pixel and the 

mean of each class's training samples. The pixel is assigned to the class with the 

shortest distance. While fast and easy to implement, it does not consider variance, 

making it less accurate for mixed or overlapping classes. 

2) Unsupervised Classification 

In unsupervised classification, the software automatically groups pixels into clusters based 

on spectral similarity, and the user labels these groups afterward. 

i. K-Means Clustering 

This is a widely used, iterative clustering method where the user defines the number 

of clusters (k). Pixels are assigned to clusters based on proximity to randomly 

chosen centroids, which are refined over iterations. It is simple but requires prior 

knowledge of how many clusters to form. 

ii. ISODATA (Iterative Self-Organizing Data Analysis Technique) 

An advanced version of K-Means, ISODATA can automatically split or merge 

clusters based on statistical criteria. This makes it more flexible and suitable for 

complex landscapes. It adjusts the number of clusters as needed and provides a more 

refined classification. 

 

Kaski District, located in the Gandaki Province of Nepal, is an ideal study area for Land 

Use/Land Cover (LULC) analysis due to its varied topography, diverse land cover types, 

and ongoing socio-economic and environmental transformations. Centered at 

approximately [83.9818, 28.2096], Kaski covers an area of about 2,017 km² and is known 

for its blend of urban centers like Pokhara, fertile agricultural lands, dense forests, lakes 

such as Phewa and Begnas, and hilly or rocky terrains. The district presents a representative 

landscape of Nepal’s mid-hill region, where rapid urbanization and tourism-driven 

development have led to noticeable land cover changes, especially the conversion of 

agricultural and vegetated areas into built-up zones. These changes pose significant 
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challenges for sustainable land use planning and require accurate, up-to-date LULC 

mapping. 

This lab report utilizes a single Landsat Collection 2 Level-2 Surface Reflectance image 

from 2025, downloaded from the USGS EarthExplorer, to generate four LULC maps: two 

unsupervised (K-Means, ISODATA) and two supervised (Maximum Likelihood, 

Minimum Distance). The Landsat program, operated by the United States Geological 

Survey (USGS) and NASA, provides moderate-resolution multispectral imagery (30m) 

across multiple spectral bands, making it suitable for broad-scale LULC classification. The 

methodology includes preprocessing steps such as compositing spectral bands and 

projecting the image, carried out using ArcMap and ENVI 5.x software. These steps ensure 

accurate representation of surface reflectance, which enhances the reliability and accuracy 

of the classification results. 
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2. Study Area 

Kaski District, located in the Gandaki Province of Nepal, is centered approximately at 

coordinates [83.9818, 28.2096]. Spanning an area of around 2,017 km², the district is 

recognized for its ecological diversity, urban development, and natural beauty. The study 

area includes a wide range of land cover types such as rapidly expanding urban areas (e.g., 

Pokhara Metropolitan City), productive agricultural lands, dense forested and vegetative 

zones, numerous water bodies (including Phewa Lake, Begnas Lake, and rivers), as well as 

bare or rocky terrain in hilly regions. Kaski’s strategic location, diverse topography, and 

increasing urban pressure make it a compelling case for analyzing LULC dynamics 

influenced by urban growth, tourism development, and environmental factors. 

 

 

 

 

  

Figure 1 : Study Area 
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3. Data and Software 

Table 1 :Data and Software 

Category 

 

Details 

 

Data Source 

 

Landsat Collection 2 Level-1 (Top-of-Atmosphere 

reflectance) or Level-2 (Surface Reflectance) 

imagery from the USGS EarthExplore 

Acquisition Year 

 

2025 (10% cloud cover) 

 

Software 

 

ENVI 5.x for data preprocessing, classification, 

visualization, and accuracy assessment 

 

Purpose 

 

Preprocessing (pan-sharpening), unsupervised 

classification (K-Means, ISODATA), supervised 

classification (Maximum Likelihood, Minimum 

Distance), and accuracy assessment 
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4. Methodology 

The methodology encompasses data acquisition, preprocessing, classification, accuracy 

assessment, and visualization in ENVI, with detailed instructions for capturing screenshots 

to document each step. 

Step 1: Data Acquisition and Import 

1. Download Landsat Imagery: 

o Access the USGS EarthExplorer (https://earthexplorer.usgs.gov). 

o Search for Landsat Collection 2 Level-2 (Surface Reflectance) imagery for Kaski 

District in 2025, ensuring cloud cover <10%. 

o Download the image in .tar format and extract the contents to access the surface 

reflectance bands: 

SR_B1, SR_B2, SR_B3, SR_B4, SR_B5, SR_B6, SR_B7, SR_B9. 

o Load all 8 bands into ArcMap, and use the Composite Bands tool to combine 

Bands 1 to 7 into a single multispectral image for further analysis. 

2. Import to ENVI: 

o Open ENVI 5.x and go to File > Open. 

o Import the projected composite image (created in ArcMap by combining Bands 1–

7). 

o If not already stacked, you can use Raster Management > Build Layer Stack to 

ensure all bands are properly aligned. 

o Verify the band order corresponds to Landsat SR_B1 to SR_B7. 

 

Step 2: Preprocessing 

1. Pan-Sharpening: 

o Navigate to Spectral > Pan Sharpening > Gram-Schmidt Pan Sharpening. 

o Select the surface reflectance image as the multispectral input and B8A as 

the panchromatic band. 

https://earthexplorer.usgs.gov/
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o Save the pan-sharpened image as .dat. 

 

Step 3: Unsupervised Classification 

1. K-Means Clustering: 

o Go to Classification > Unsupervised > K-Means. 

o Select the pan-sharpened image, set the number of classes to 5 (Urban, 

Vegetation, Water, Barren Land, Agriculture), iterations = 10, and change 

threshold = 5%. 

o Run the classification and save the output as KMeans_LULC.tif. 

o Assign a color scheme: Urban (Red), Vegetation (Green), Water (Blue), 

Bare Soil (Yellow), Bare Land (Orange). 

Figure 2 : Pan Sharpening 
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o Generate the first unsupervised LULC map . 

2. ISODATA Clustering: 

o Go to Classification > Unsupervised > ISODATA. 

o Use the same settings: 5 classes, iterations = 10, minimum classes = 3, 

maximum classes = 7. 

o Run the classification and save the output as ISODATA_LULC.tif with the 

same color scheme. 

o Generate the second unsupervised LULC map .  

Figure 3 : K-Means Clustering: 

Figure 4 : ISODATA Clustering 
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o  

Step 4: Supervised Classification 

1. Collect Training Data: 

o Use the Region of Interest (ROI) tool (Tools > Region of Interest > ROI 

Tool): 

 Zoom into the pan-sharpened image and select ROIs for Snow 

Cover, Built Up, Vegetation, Water Body, Barren Land, and 

Agriculture. 

 Reference high-resolution imagery (e.g., Google Earth, accessed via 

a web browser) to ensure accurate class assignment. 

o Save the ROIs as Training_ROIs.roi. 

 

Figure 5 : ROI 

2. Maximum Likelihood Classification: 

o Navigate to Classification > Supervised > Maximum Likelihood. 

o Load the pan-sharpened image and Training_ROIs.roi, and set the 

probability threshold to 0.1. 

o Run the classification and save the output with the same color scheme. 
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o Generate the first supervised LULC map.  

 

  

 Figure 6 : Maximum Likelihood Classification 
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3. Minimum Distance Classification: 

o Navigate to Classification > Supervised > Minimum Distance. 

o Load the same image and Training_ROIs.roi, select all bands, and set the 

maximum distance error 

o or to 0.5 (in reflectance units). 

o Run the classification and save the output as MD_LULC.tif with the same 

color scheme. 

o Generate the second supervised LULC map . 

 

Step 5: Visualization and Export 

1. Display LULC Maps: 

o Load all four LULC maps in ENVI. 

o Apply consistent color schemes and display in the Image Window for 

comparison. 

2. Export Results: 

o Export each map as a GeoTIFF using File > Export to TIFF. 

o Save to a designated folder (e.g., Kaski_LULC_2025) with filenames 

indicating the classification method. 

Figure 7 :Minimum Distance Classification 
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o Export a composite image of all four maps for presentation using File > Save 

As > PNG for inclusion in the report. 

5. Results 

The LULC classification produced four maps, each highlighting different aspects of land 

cover distribution in Kaski District for 2025: 

 

Map 1 (K-Means): Identified four clusters with reasonable separation of urban and 

vegetative areas.  

  

Figure 8 :Map 1 (K-Means) 
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Map 2 (ISODATA): Provided better delineation of Snow Cover, accurately identifying 

snow. Urban areas were less distinct compared to K-Means, with some misclassification 

into Agriculture Land. The ISODATA algorithm’s iterative splitting and merging improved 

cluster separation for water but struggled with heterogeneous urban zones.  

 

  

Figure 9 : Map 2 (ISODATA) 
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Map 3 (Maximum Likelihood): Achieved high accuracy with clear delineation of snow 

cover,urban and vegetation classes. Agricultural areas were well-separated, but some water 

bodies were confused with shadowed urban areas due to spectral overlap.  

 

 

  

Figure 10 :Map 3 (Maximum Likelihood) 
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Map 4 (Minimum Distance): Demonstrated lower accuracy compared to Maximum 

Likelihood. It performed well in distinguishing snow cover  but had challenges with 

agriculture forest and water bodies due to its reliance on mean spectral values.  

 

 

 

 

 

 

 

 

 

 

 

Figure 11  :MAP 4 (Minimum Distance) 
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6. Conclusion 

This lab exercise successfully demonstrated the application of Landsat imagery and ENVI 

software for Land Use/Land Cover (LULC) classification in Kaski District, Nepal, for the 

year 2025. The workflow included preprocessing steps such as compositing surface 

reflectance bands, projection, and the generation of four LULC maps using unsupervised 

(K-Means, ISODATA) and supervised (Maximum Likelihood, Minimum Distance) 

classification techniques. These methods effectively mapped land use patterns across the 

district, revealing notable changes such as urban expansion around Pokhara, reduction in 

agricultural land, and shifts in vegetative cover. Among the methods, supervised 

classification, especially Maximum Likelihood, yielded the highest classification accuracy, 

emphasizing the critical role of training data. The outcomes offer valuable insights for 

sustainable land management, urban planning, and environmental monitoring in Kaski, 

demonstrating the practical utility of remote sensing and GIS tools in Geomatics 

Engineering. 
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